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Image Acquisition 

Configuration of the 
Microscope 

 

Turning on the Microscope 
 Turn on Parts 1,2, 3 and the Video Monitor 

o 4 creates an optional fluorescent light 
 Turn on the incandescent light (for white light.)  

  
 The fluorescent and the incandescent lights 

require time to heat up so that they can emit an 
accurate light.  
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Choosing the right lens 
 Select the 40x lens 

 

Opening the Shutter and Choosing the 
Correct Filter (Optional) 
The microscope contains fluorescent filters also.  

 



http://www.med.unc.edu/lccc/iac/Protocols/downloads.htm 7

Gross and fine focus adjustment 

 

Adjusting the voltage 

 
 Optimal voltage: 7-9V 
 If a very high voltage is required ( 11-12V), it 

may be necessary to replace the bulb.  
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Movement of the stage using the 
joystick 

 The stage will move slowly when the joystick is 
moved without pressing any buttons. 

 The stage will move quickly if the center button 
on the joystick is depressed. 
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Configuration of the video 
camera 

 

Adjusting the White Balance 
 The white balance adjusts for the color 

temperature of the light (basically a yellow or 
blue tint.) 

 Find an all white portion of the slide with the 
joystick, and then press the AWB (for Auto 
White Balance) button.  

 
 Manual Adjustments can be made by pressing 

the Gain button.  
o Note: the Button takes about 2 seconds 

to take effect on screen. After being 
pressed about 10 times it will cycle back 
to a lower setting and begin increasing 
incrementally again.  
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Adjusting the Exposure 
 

 
 

 Auto 
o Pressing the �“Auto�” button will 

cause the camera to 
automatically select the 
correct exposure.  

 Manual 
o If one is not pleased with the 

automatic adjustment, one 
can use the manual knob to 
make fine adjustments to the 
exposure.  
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Adding/Removing the Status Text 

 
 Above is an example of the Status Text.  

 

 
 Press the ON/OFF Button under 

STATUS on the Camera Controller. 
 Press COLOR to change the color 

of the text. 
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Use of Image Pro Plus 5.0 
 Camera MUST be on before using Image Pro 

Plus 5.0. 
 Open Image Pro Plus 5.0. 
 When asked what type of toolbar you would like, 

choose �“Complete.�” 

 
 Click on the video camera icon. 
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 Click �“Start Preview.�” 

 
 Once image has been selected, click �“S�” 

meaning �“Stop.�” 

 
 Click �“Snap.�” 

 
 Click File > Save As and give a name to your 

image. 
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 Make note of where you save the images. You 

can see where the images are by looking at the 
top of the window. This will be important later. 
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Running RGB Data Collect 
Macro 

 
Open the Macro 

 Choose Macro > Macro 

 
 If RGBDataCollect appears, click 

RGBDataCollect and skip to page 17. 
Otherwise, Click �“Change�” and follow these 
instructions. 
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 Find the location of RGBDataCollect.scr and 
click �“Open.�” 
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 Highlight RGBDataCollect.scr and choose 
�“Run.�” 
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 The following Dialog Box will display: 

 
 Click �“Open.�” 

 
 
 Select one of your already saved images and 

click �“Open.�”  
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 Once an image is displayed, Press �“Continue.�” 

 
 The following Dialog box will now appear: 

 
 Select the �“Magic Wand�” Tool by clicking the 

kidney shaped icon. 
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 Select Positive or Negative cells with �“Magic 
Wand�” tool. If you like the selections in red, hold 
down CTRL, and make another selection. If a 
selection is in red and you are unhappy with it, 
click another cell. Once you are happy with what 
is in red, hold down CTRL and it will be made 
green and added to the selection.  

 
 

 
 Adjust the sensitivity of the magic wand with the 

following dialog box, the greater the number the 
more each click will encompass. 

 
 Click continue 
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 Then the next dialog box will appear: 

 
 Click the eyedropper tool in the Segmentation > 

Color Cube Based Dialog Box.  

 
 Click inside the selected cells (green circles) so 

that they become entirely red. If everything is 
working, the cells should look like this: 
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 Once you are done, click Continue. 

  
 Click �“Yes.�” 

 
 Click on Objects (in the picture) you do not want 

to count in the final analysis �– a number will not 
appear next to them if they are not being 
counted.   

 
 Click �“Yes.�” 
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 Click �“Continue.�” 
 Then click �“no.�” 
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Parameter Training 
Exporting the Data to Excel 

 Select �“Export�” tab. 

 
 Select �“To the Clipboard.�”  
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 Click �“Export Now.�” 

 
 Open a new spread sheet in Excel and click the 

upper left-hand corner. 
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 Go to the edit menu and click paste. (Edit > 
Paste). 

 
 Go back and run the RGBDataCollect macro 

again (page 14,) collecting more data from 
positive (or if you have just done negative, 
negative) nuclei. For best results, one would 
have data from 10 positive nuclei from 10 
different images and 10 negative nuclei from 10 
different images. 
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Labeling the data positive or 
negative 

 Create a new column to the right of the RGB 
Data, called class. 

 1 will be used to denote positive. 
 2 will be used to denote negative. 

 
 click the black corner of the cell and drag it 

down so that all of the positive samples are 
marked �“1.�” 

    
 Continue to add data by running the 

RGBDataCollect macro on page 27 until 
you have a data set of an appropriate size. 
Add Negative data after the Positive data 
and label it with a 2.  
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Formatting the data from excel 
into a text document the 
analysis program can 
understand. 

 First, copy all the data into sheet 2 by hitting 
CTRL + A then going to edit > copy. Then 
delete all rows of text. Also Delete the Area 
column and the number column. That 
should leave 4 columns of data: Red, 
Green, Blue, and Class. 
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 Then delete all rows of text. Also Delete the 
Area column and the number column. That 
should leave 4 columns of data: Red, 
Green, Blue, and Class. 

 
 To delete the rows of text, click the top of 

the column and drag to the next.  

 
 Then right click the columns.  
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 Then, click delete. 

 
 Unwanted rows are deleted similarly: Click 

and drag. 

 
 Right click. 

 



http://www.med.unc.edu/lccc/iac/Protocols/downloads.htm 31

 Choose delete.  

  
 When done, your table should appear like 

this: 4 columns, the first three for Red, 
Green, and Blue data respectively (values 
between 0 and 255,) and the last for class 
data with a value of 1 or 2.  
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Saving from Excel or Copying to Notepad 
 There are two methods to take the data from 

Excel and get it ready for the UNC-Roswell Park 
Prostate Cancer Image Processing Program: 1) 
Save the data from Excel as a tab-delimited text 
file, 2) Copy the data into Notepad and save as 
a text file.  

1) Saving as a tab-delimited text file 
 Go to File>Save As 
 Next to �“Save as Type.�”  

Choose �“Text (Tab delimited).�” 

 

 
 Choose a Filename and Click Save. 
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2) Copying the data to Notepad 
 Highlight all of the data. Then Copy the data 

(Edit > Copy).  
 Open Notepad 

(Start>Programs>Accessories>Note
pad). 

 
 Paste the data (Edit > Paste).  
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 Save the data with a recognizable filename in a 
location where it can be found. Check the 
location by looking at the top of the box. Then 
Click Save.  
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Running Parameter Training 
 Open the UNC-Roswell Park Prostate Cancer 

Image Processing Program by going to Start > 
programs> Java WebStart > Java Web Start 
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 Select the UNC-Roswell Park Prostate Cancer 
Image Processing Program and click start.  

 
 If the �“UNC-Roswell Park Prostate Cancer 

Image Processing Program�” does not appear in 
the window as it does above, Type the following 
URL into the Location Bar:  

http://www.med.unc.edu/lccc/iac/Protocols/unc.jnlp 
 NOTE: The UNC web server is case-sensitive. 

Therefore, the P in protocols must be 
capitalized.  
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Then go to File and Click Parameter training 
(File>Parameter Training). 

 
 Choose the text file containing the RGB and 

class data and click �“Open.�” Click the top of the 
box to find the location where the data was 
saved. (See page 32 or 34.) 
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 Click �“Ok.�” 
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Saving the Parameters 
 Click save parameters. For simplicity, name the 

file your_filename_here.par 
 You can examine the numbers on this screen to 

see if your parameters are acceptable. The two 
circled numbers should be greater than 85%. 
The number on the left shows that the data set 
must be added to and the parameters retrained. 

 
 Then click �“Use Parameters.�” 
 Click �“Close.�” 
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Loading the Parameters 
 If you have already clicked use parameters, it is 

not necessary to load the parameters. 
 To load the parameters click browse near 

�“config file.�”  

 

Modifying the Parameters before 
performing Analysis 
 

 Click �“Modify.�” 

 

 
 Then Change �“Upper Cell Size�” to 400 and 

change �“Lower Cell Size�” to 100.  
 Click �“Ok.�” 
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Running the UNC-
Roswell Park Prostate 
Cancer Image 
Processing Program 
Choosing an Output Directory 

 The �“Output Directory�” is the directory where the 
program will place your results.  

 To choose an output directory click browse in 
the section of the program for the output 
directory. 

  
 After clicking browse, you can create a new 

folder by clicking the following icon. 

 
 Once you are content with the location of your 

output folder, click �“Open.�” 
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Adding Images to be 
processed 

 Click �“Add�” to input images into program.  

 
 

 Click up at the top of the window near to �“Look 
In�” to choose the folder where you previously 
saved images. (See page 14.) 
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 Then select multiple images by first clicking an 
image at the top of the box, then while holding 
down shift, click an image at the bottom of the 
box.  

 
 Then click �“Open.�” 

 

http://www.med.unc.edu/lccc/iac/Protocols/downloads.htm 44 

 When done, the window should appear like this: 
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Processing the Images 
 Once the output directory has been selected 

and the images have been loaded, choose the 
output format. The �“Short�” format simply 
provides the end results for each entire image. 
The �“Long�” format provides data for each 
individual scored point. Long is probably best for 
determining technique.  

 
 Next, Click Process. 

 
 The results will be placed in the �“output 

directory.�” 
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Troubleshooting 

Using the color bars  
 To make sure that the camera is 

communicating with the computer, press the 
�“COLOR BAR�” button. This will generate a 
color bar pattern coming out of the Camera 
Controller which should be able to be seen 
on the computer and the Video Monitor.  

 
 

        
 When viewing the colors bars on the Video 

Monitor, the brightness and contrast could be 
configured so that a very slight gray bar can be 
seen underneath the red bar.  
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Installing the IPP Environment 
 If RGBDataCollect outputs Red, Green, and 

Blue data outside of the 0 to 255 range, it is 
necessary to install the Image Pro Plus 
Environment File, �“Swaroop01.env�”.  

 Installing the file requires downloading the file 
from this URL 

 http://www.med.unc.edu/lccc/iac/Protocols/Swaroop01.env 
 NOTE: The UNC web server is case-sensitive, 

meaning that the P in �“protocols�” and the S in 
�“Swaroop01.env�” must be capitalized.  

 Then place the file into the directory containing 
�“IPWIN32.exe�” (most likely the C:\IPWIN5\ 
directory.)  
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